import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*?#.*(?:\\n|$)|(\\([A-Za-z0-9\\s\\-]*\\))";
final String string = "# Caught Stealing from Something (Warning) (3300-3599)\n"
+ "...(test)..., ...(Next)..., ...(Warning)... and so on\n"
+ "# this is a commented line (really)\n"
+ "This is not a commented like\n"
+ "This line has (items you are interested in) ok\n"
+ "This like has (multiple) (items)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}