// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*?#.*(?:\n|$)|(\([A-Za-z0-9\s\-]*\))").unwrap();
let string = "# Caught Stealing from Something (Warning) (3300-3599)
...(test)..., ...(Next)..., ...(Warning)... and so on
# this is a commented line (really)
This is not a commented like
This line has (items you are interested in) ok
This like has (multiple) (items)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}