import Foundation
let pattern = ##"\s*?#.*(?:\n|$)|(\([A-Za-z0-9\s\-]*\))"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# Caught Stealing from Something (Warning) (3300-3599)
...(test)..., ...(Next)..., ...(Warning)... and so on
# this is a commented line (really)
This is not a commented like
This line has (items you are interested in) ok
This like has (multiple) (items)
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)