re = /\s*?#.*(?:\n|$)|(\([A-Za-z0-9\s\-]*\))/m
str = '# Caught Stealing from Something (Warning) (3300-3599)
...(test)..., ...(Next)..., ...(Warning)... and so on
# this is a commented line (really)
This is not a commented like
This line has (items you are interested in) ok
This like has (multiple) (items)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end