#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(<blockquote\s*[^>]*>(.*)<a\s*[^>]*(?:href=["']([^\'\"]+))\s*[^>]*>(?:[\S\s]*?)<\/a>(.*)<\/blockquote>)"
Local $sString = "<blockquote class="bs-callout bs-callout-info comment"><div class="author"><a class="comm_link" href="#comment_1"> Лев Сорокин says:</a></div> ÑброÑить пароль <a href="#user_4">Тимур Данилов</a> в <a href="#supplier_1">ООО Ромашка</a></blockquote>" & @CRLF & _
"СброÑил" & @CRLF & _
"<blockquote class="bs-callout bs-callout-info comment"><div class="author"><a class="comm_link" href="#comment_2"> Ðнджела шубина says:</a></div>Ðичего не делать</blockquote><br>" & @CRLF & _
"Ок =)" & @CRLF & _
"<blockquote class="bs-callout bs-callout-info comment"><div class="author"><a class="comm_link" href="#comment_4"> Людмила ÐекраÑова says:</a></div>aaaaa<blockquote class="bs-callout bs-callout-info comment"><div class="author"><a class="comm_link" href="#comment_5">comment_1</a></div> fffffff </blockquote>qqqq<div></div></blockquote>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")