const regex = /(<blockquote\s*[^>]*>(.*)<a\s*[^>]*(?:href=["']([^\'\"]+))\s*[^>]*>(?:[\S\s]*?)<\/a>(.*)<\/blockquote>)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<blockquote\\s*[^>]*>(.*)<a\\s*[^>]*(?:href=["\']([^\\\'\\"]+))\\s*[^>]*>(?:[\\S\\s]*?)<\\\/a>(.*)<\\\/blockquote>)', 'gi')
const str = `<blockquote class="bs-callout bs-callout-info comment"><div class="author"><a class="comm_link" href="#comment_1"> Лев Сорокин says:</a></div> ÑброÑить пароль <a href="#user_4">Тимур Данилов</a> в <a href="#supplier_1">ООО Ромашка</a></blockquote>
СброÑил
<blockquote class="bs-callout bs-callout-info comment"><div class="author"><a class="comm_link" href="#comment_2"> Ðнджела шубина says:</a></div>Ðичего не делать</blockquote><br>
Ок =)
<blockquote class="bs-callout bs-callout-info comment"><div class="author"><a class="comm_link" href="#comment_4"> Людмила ÐекраÑова says:</a></div>aaaaa<blockquote class="bs-callout bs-callout-info comment"><div class="author"><a class="comm_link" href="#comment_5">comment_1</a></div> fffffff </blockquote>qqqq<div></div></blockquote>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}