re = /(<blockquote\s*[^>]*>(.*)<a\s*[^>]*(?:href=["']([^\'\"]+))\s*[^>]*>(?:[\S\s]*?)<\/a>(.*)<\/blockquote>)/i
str = '<blockquote class="bs-callout bs-callout-info comment"><div class="author"><a class="comm_link" href="#comment_1"> Лев Сорокин says:</a></div> ÑброÑить пароль <a href="#user_4">Тимур Данилов</a> в <a href="#supplier_1">ООО Ромашка</a></blockquote>
СброÑил
<blockquote class="bs-callout bs-callout-info comment"><div class="author"><a class="comm_link" href="#comment_2"> Ðнджела шубина says:</a></div>Ðичего не делать</blockquote><br>
Ок =)
<blockquote class="bs-callout bs-callout-info comment"><div class="author"><a class="comm_link" href="#comment_4"> Людмила ÐекраÑова says:</a></div>aaaaa<blockquote class="bs-callout bs-callout-info comment"><div class="author"><a class="comm_link" href="#comment_5">comment_1</a></div> fffffff </blockquote>qqqq<div></div></blockquote>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end