using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<blockquote\s*[^>]*>(.*)<a\s*[^>]*(?:href=[""']([^\'\""]+))\s*[^>]*>(?:[\S\s]*?)<\/a>(.*)<\/blockquote>)";
string input = @"<blockquote class=""bs-callout bs-callout-info comment""><div class=""author""><a class=""comm_link"" href=""#comment_1""> Лев Сорокин says:</a></div> ÑброÑить пароль <a href=""#user_4"">Тимур Данилов</a> в <a href=""#supplier_1"">ООО Ромашка</a></blockquote>
СброÑил
<blockquote class=""bs-callout bs-callout-info comment""><div class=""author""><a class=""comm_link"" href=""#comment_2""> Ðнджела шубина says:</a></div>Ðичего не делать</blockquote><br>
Ок =)
<blockquote class=""bs-callout bs-callout-info comment""><div class=""author""><a class=""comm_link"" href=""#comment_4""> Людмила ÐекраÑова says:</a></div>aaaaa<blockquote class=""bs-callout bs-callout-info comment""><div class=""author""><a class=""comm_link"" href=""#comment_5"">comment_1</a></div> fffffff </blockquote>qqqq<div></div></blockquote>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}