using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?<track>\d{1,3}) \s*[\s-]\s*)?
(?:(?<artist>.+?) \s*-\s*)?
(?<title>.+)
(?<ext> \.mp3)";
string input = @"01 Example Artist - Example Song.mp3
01 Example Song.mp3 (In this example, there's no artist so that group should be null)
Example Artist - Example Song.mp3
Example Song.mp3 (Again, no artist)";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}