// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^(?:(?<track>\d{1,3}) \s*[\s-]\s*)?
(?:(?<artist>.+?) \s*-\s*)?
(?<title>.+)
(?<ext> \.mp3)").unwrap();
let string = "01 Example Artist - Example Song.mp3
01 Example Song.mp3 (In this example, there's no artist so that group should be null)
Example Artist - Example Song.mp3
Example Song.mp3 (Again, no artist)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}