use strict;
my $str = '01 Example Artist - Example Song.mp3
01 Example Song.mp3 (In this example, there\'s no artist so that group should be null)
Example Artist - Example Song.mp3
Example Song.mp3 (Again, no artist)';
my $regex = qr/^(?:(?<track>\d{1,3}) \s*[\s-]\s*)?
(?:(?<artist>.+?) \s*-\s*)?
(?<title>.+)
(?<ext> \.mp3)/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}