import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?<track>\\d{1,3}) \\s*[\\s-]\\s*)?\n"
+ "(?:(?<artist>.+?) \\s*-\\s*)?\n"
+ "(?<title>.+)\n"
+ "(?<ext> \\.mp3)";
final String string = "01 Example Artist - Example Song.mp3\n\n"
+ "01 Example Song.mp3 (In this example, there's no artist so that group should be null)\n\n"
+ "Example Artist - Example Song.mp3\n\n"
+ "Example Song.mp3 (Again, no artist)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}