const regex = /^(?:(?<track>\d{1,3}) \s*[\s-]\s*)?
(?:(?<artist>.+?) \s*-\s*)?
(?<title>.+)
(?<ext> \.mp3)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?<track>\\d{1,3}) \\s*[\\s-]\\s*)?
(?:(?<artist>.+?) \\s*-\\s*)?
(?<title>.+)
(?<ext> \\.mp3)', 'gm')
const str = `01 Example Artist - Example Song.mp3
01 Example Song.mp3 (In this example, there's no artist so that group should be null)
Example Artist - Example Song.mp3
Example Song.mp3 (Again, no artist)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}