re = /^(?:(?<track>\d{1,3}) \s*[\s-]\s*)?
(?:(?<artist>.+?) \s*-\s*)?
(?<title>.+)
(?<ext> \.mp3)/mx
str = '01 Example Artist - Example Song.mp3
01 Example Song.mp3 (In this example, there\'s no artist so that group should be null)
Example Artist - Example Song.mp3
Example Song.mp3 (Again, no artist)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end