import Foundation
let pattern = #"""
^(?:(?<track>\d{1,3}) \s*[\s-]\s*)?
(?:(?<artist>.+?) \s*-\s*)?
(?<title>.+)
(?<ext> \.mp3)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
01 Example Artist - Example Song.mp3
01 Example Song.mp3 (In this example, there's no artist so that group should be null)
Example Artist - Example Song.mp3
Example Song.mp3 (Again, no artist)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)