# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\w]+/X/g;t' <<< "program p;
begin
write('x');
end."