import re
regex = re.compile(r"[^\w]+")
test_str = ("program p;\n"
"begin\n"
" write('x');\n"
"end.")
subst = "X"
result = regex.sub(subst, test_str)
if result:
print(result)