using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\w]+";
string substitution = @"X";
string input = @"program p;
begin
write('x');
end.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}