package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\w]+`)
var str = `program p;
begin
write('x');
end.`
var substitution = "X"
fmt.Println(re.ReplaceAllString(str, substitution))
}