$re = '/[^\w]+/';
$str = 'program p;
begin
write(\'x\');
end.';
$subst = "X";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;