use strict;
my $str = 'program p;
begin
write(\'x\');
end.';
my $regex = qr/[^\w]+/p;
my $subst = 'X';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";