# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\[a\])([^\[]+)(\[\\/a\])/<a href='$2'>$2<\/a>/g;t' <<< "[a]http://first.com/hi_underscoredot.htm[/a] [a]http://secondinoneline.com/hi_.htm[/a]"