using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[a\])([^\[]+)(\[\/a\])";
string substitution = @"<a href='$2'>$2</a>";
string input = @"[a]http://first.com/hi_underscoredot.htm[/a] [a]http://secondinoneline.com/hi_.htm[/a]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}