package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[a\])([^\[]+)(\[\/a\])`)
var str = `[a]http://first.com/hi_underscoredot.htm[/a] [a]http://secondinoneline.com/hi_.htm[/a]`
var substitution = "<a href='$2'>$2</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}