use strict;
my $str = '[a]http://first.com/hi_underscoredot.htm[/a] [a]http://secondinoneline.com/hi_.htm[/a]';
my $regex = qr/(\[a\])([^\[]+)(\[\/a\])/p;
my $subst = '<a href=\'$2\'>$2</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";