const regex = /(\[a\])([^\[]+)(\[\/a\])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[a\\])([^\\[]+)(\\[\\\/a\\])', 'g')
const str = `[a]http://first.com/hi_underscoredot.htm[/a] [a]http://secondinoneline.com/hi_.htm[/a]`;
const subst = `<a href='$2'>$2</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);