$re = '/(\[a\])([^\[]+)(\[\/a\])/';
$str = '[a]http://first.com/hi_underscoredot.htm[/a] [a]http://secondinoneline.com/hi_.htm[/a]';
$subst = "<a href='$2'>$2</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;