#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<!\[CDATA\[(.*|\n|.*\n.*)&#x.....;(.*|\n|.*\n.*)]]"
Local $sString = "" & @CRLF & _
"<journal-meta>" & @CRLF & _
"<issn>Modern data <![CDATA[ data is <>?":{}|\][;'." & @CRLF & _
"/, ']]> is needed with dummy content. we are good to go.</issn>" & @CRLF & _
"<issn>Modern data <![CDATA[ data is not proper ' sdgfs ]]> is needed with dummy content. we are good to go.</issn>" & @CRLF & _
"<issn>Modern data <![CDATA[ " & @CRLF & _
"data is not proper ']]> is needed with dummy content. ' we are good to go.</issn>" & @CRLF & _
"" & @CRLF & _
"<issn>Modern data <![CDATA[" & @CRLF & _
"']]> is needed with dummy content. we are good to go.</issn>" & @CRLF & _
"" & @CRLF & _
"<issn2><![CDATA[é]]>Modern data is needed with dummy content. we are good to go.</issn2>" & @CRLF & _
"<issn3><![CDATA[']]>Modern data is needed with dummy content. we are good to go.</issn3>" & @CRLF & _
"<issn4><![CDATA[&]]>Modern data is needed with dummy content. we are good to go.</issn4>" & @CRLF & _
"<issn5><![CDATA[–]]>Modern data is needed with dummy content. we are good to go.</issn5>" & @CRLF & _
"</journal-meta>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")