const regex = /<!\[CDATA\[(.*|\n|.*\n.*)&#x.....;(.*|\n|.*\n.*)]]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<!\\[CDATA\\[(.*|\\n|.*\\n.*)&#x.....;(.*|\\n|.*\\n.*)]]', '')
const str = `
<journal-meta>
<issn>Modern data <![CDATA[ data is <>?":{}|\\][;'.
/, ']]> is needed with dummy content. we are good to go.</issn>
<issn>Modern data <![CDATA[ data is not proper ' sdgfs ]]> is needed with dummy content. we are good to go.</issn>
<issn>Modern data <![CDATA[
data is not proper ']]> is needed with dummy content. ' we are good to go.</issn>
<issn>Modern data <![CDATA[
']]> is needed with dummy content. we are good to go.</issn>
<issn2><![CDATA[é]]>Modern data is needed with dummy content. we are good to go.</issn2>
<issn3><![CDATA[']]>Modern data is needed with dummy content. we are good to go.</issn3>
<issn4><![CDATA[&]]>Modern data is needed with dummy content. we are good to go.</issn4>
<issn5><![CDATA[–]]>Modern data is needed with dummy content. we are good to go.</issn5>
</journal-meta>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}