package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<!\[CDATA\[(.*|\n|.*\n.*)&#x.....;(.*|\n|.*\n.*)]]`)
var str = `
<journal-meta>
<issn>Modern data <![CDATA[ data is <>?":{}|\][;'.
/, ']]> is needed with dummy content. we are good to go.</issn>
<issn>Modern data <![CDATA[ data is not proper ' sdgfs ]]> is needed with dummy content. we are good to go.</issn>
<issn>Modern data <![CDATA[
data is not proper ']]> is needed with dummy content. ' we are good to go.</issn>
<issn>Modern data <![CDATA[
']]> is needed with dummy content. we are good to go.</issn>
<issn2><![CDATA[é]]>Modern data is needed with dummy content. we are good to go.</issn2>
<issn3><![CDATA[']]>Modern data is needed with dummy content. we are good to go.</issn3>
<issn4><![CDATA[&]]>Modern data is needed with dummy content. we are good to go.</issn4>
<issn5><![CDATA[–]]>Modern data is needed with dummy content. we are good to go.</issn5>
</journal-meta>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}