# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<!\[CDATA\[(.*|\n|.*\n.*)&#x.....;(.*|\n|.*\n.*)]]"
test_str = ("\n"
"<journal-meta>\n"
"<issn>Modern data <![CDATA[ data is <>?\":{}|\\][;'.\n"
"/, ']]> is needed with dummy content. we are good to go.</issn>\n"
"<issn>Modern data <![CDATA[ data is not proper ' sdgfs ]]> is needed with dummy content. we are good to go.</issn>\n"
"<issn>Modern data <![CDATA[ \n"
"data is not proper ']]> is needed with dummy content. ' we are good to go.</issn>\n\n"
"<issn>Modern data <![CDATA[\n"
"']]> is needed with dummy content. we are good to go.</issn>\n\n"
"<issn2><![CDATA[é]]>Modern data is needed with dummy content. we are good to go.</issn2>\n"
"<issn3><![CDATA[']]>Modern data is needed with dummy content. we are good to go.</issn3>\n"
"<issn4><![CDATA[&]]>Modern data is needed with dummy content. we are good to go.</issn4>\n"
"<issn5><![CDATA[–]]>Modern data is needed with dummy content. we are good to go.</issn5>\n"
"</journal-meta>")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.