import Foundation
let pattern = ##"<!\[CDATA\[(.*|\n|.*\n.*)&#x.....;(.*|\n|.*\n.*)]]"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<journal-meta>
<issn>Modern data <![CDATA[ data is <>?":{}|\][;'.
/, ']]> is needed with dummy content. we are good to go.</issn>
<issn>Modern data <![CDATA[ data is not proper ' sdgfs ]]> is needed with dummy content. we are good to go.</issn>
<issn>Modern data <![CDATA[
data is not proper ']]> is needed with dummy content. ' we are good to go.</issn>
<issn>Modern data <![CDATA[
']]> is needed with dummy content. we are good to go.</issn>
<issn2><![CDATA[é]]>Modern data is needed with dummy content. we are good to go.</issn2>
<issn3><![CDATA[']]>Modern data is needed with dummy content. we are good to go.</issn3>
<issn4><![CDATA[&]]>Modern data is needed with dummy content. we are good to go.</issn4>
<issn5><![CDATA[–]]>Modern data is needed with dummy content. we are good to go.</issn5>
</journal-meta>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}