using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<!\[CDATA\[(.*|\n|.*\n.*)&#x.....;(.*|\n|.*\n.*)]]";
string input = @"
<journal-meta>
<issn>Modern data <![CDATA[ data is <>?"":{}|\][;'.
/, ']]> is needed with dummy content. we are good to go.</issn>
<issn>Modern data <![CDATA[ data is not proper ' sdgfs ]]> is needed with dummy content. we are good to go.</issn>
<issn>Modern data <![CDATA[
data is not proper ']]> is needed with dummy content. ' we are good to go.</issn>
<issn>Modern data <![CDATA[
']]> is needed with dummy content. we are good to go.</issn>
<issn2><![CDATA[é]]>Modern data is needed with dummy content. we are good to go.</issn2>
<issn3><![CDATA[']]>Modern data is needed with dummy content. we are good to go.</issn3>
<issn4><![CDATA[&]]>Modern data is needed with dummy content. we are good to go.</issn4>
<issn5><![CDATA[–]]>Modern data is needed with dummy content. we are good to go.</issn5>
</journal-meta>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}