use strict;
my $str = '
<journal-meta>
<issn>Modern data <![CDATA[ data is <>?":{}|\\][;\'.
/, ']]> is needed with dummy content. we are good to go.</issn>
<issn>Modern data <![CDATA[ data is not proper ' sdgfs ]]> is needed with dummy content. we are good to go.</issn>
<issn>Modern data <![CDATA[
data is not proper ']]> is needed with dummy content. ' we are good to go.</issn>
<issn>Modern data <![CDATA[
']]> is needed with dummy content. we are good to go.</issn>
<issn2><![CDATA[é]]>Modern data is needed with dummy content. we are good to go.</issn2>
<issn3><![CDATA[']]>Modern data is needed with dummy content. we are good to go.</issn3>
<issn4><![CDATA[&]]>Modern data is needed with dummy content. we are good to go.</issn4>
<issn5><![CDATA[–]]>Modern data is needed with dummy content. we are good to go.</issn5>
</journal-meta>';
my $regex = qr/<!\[CDATA\[(.*|\n|.*\n.*)&#x.....;(.*|\n|.*\n.*)]]/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}