#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(-?\d){10,14}$)3[0-9-]{9,18}$"
Local $sString = "312345678" & @CRLF & _
"312345678912345" & @CRLF & _
"3-12345678" & @CRLF & _
"3-12345678912345" & @CRLF & _
"3-1-2-3-4-5-67891234" & @CRLF & _
"12345678901" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"3-1-23456789" & @CRLF & _
"3-1-2-34567891234" & @CRLF & _
"3123456789" & @CRLF & _
"31234567891234" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")