use strict;
my $str = '312345678
312345678912345
3-12345678
3-12345678912345
3-1-2-3-4-5-67891234
12345678901
3-1-23456789
3-1-2-34567891234
3123456789
31234567891234
';
my $regex = qr/^(?=(-?\d){10,14}$)3[0-9-]{9,18}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}