import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(-?\\d){10,14}$)3[0-9-]{9,18}$";
final String string = "312345678\n"
+ "312345678912345\n"
+ "3-12345678\n"
+ "3-12345678912345\n"
+ "3-1-2-3-4-5-67891234\n"
+ "12345678901\n\n\n"
+ "3-1-23456789\n"
+ "3-1-2-34567891234\n"
+ "3123456789\n"
+ "31234567891234\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}