re = /^(?=(-?\d){10,14}$)3[0-9-]{9,18}$/m
str = '312345678
312345678912345
3-12345678
3-12345678912345
3-1-2-3-4-5-67891234
12345678901
3-1-23456789
3-1-2-34567891234
3123456789
31234567891234
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end