const regex = /^(?=(-?\d){10,14}$)3[0-9-]{9,18}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(-?\\d){10,14}$)3[0-9-]{9,18}$', 'gm')
const str = `312345678
312345678912345
3-12345678
3-12345678912345
3-1-2-3-4-5-67891234
12345678901
3-1-23456789
3-1-2-34567891234
3123456789
31234567891234
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}