import re
regex = re.compile(r"^(?=(-?\d){10,14}$)3[0-9-]{9,18}$", flags=re.MULTILINE)
test_str = ("312345678\n"
"312345678912345\n"
"3-12345678\n"
"3-12345678912345\n"
"3-1-2-3-4-5-67891234\n"
"12345678901\n\n\n"
"3-1-23456789\n"
"3-1-2-34567891234\n"
"3123456789\n"
"31234567891234\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")