# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d*\s?\d+\\/\d+"*\s*(in|")\sx\s\d*\s?\d+\\/\d+"*\s*(in|")(*SKIP)(*FAIL)|\d*\s?\d+\\/\d+"*\s*(in|")/ /gm;t' <<< "A product description with 12 1/2\" in it.
Product description with 19 3/4\" x 19 5/8\" in it."