import re
regex = re.compile(r"\d*\s?\d+\/\d+\"*\s*(in|\")\sx\s\d*\s?\d+\/\d+\"*\s*(in|\")(*SKIP)(*FAIL)|\d*\s?\d+\/\d+\"*\s*(in|\")", flags=re.MULTILINE)
test_str = ("A product description with 12 1/2\" in it.\n"
"Product description with 19 3/4\" x 19 5/8\" in it.")
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)