const regex = /\d*\s?\d+\/\d+"*\s*(in|")\sx\s\d*\s?\d+\/\d+"*\s*(in|")(*SKIP)(*FAIL)|\d*\s?\d+\/\d+"*\s*(in|")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d*\\s?\\d+\\\/\\d+"*\\s*(in|")\\sx\\s\\d*\\s?\\d+\\\/\\d+"*\\s*(in|")(*SKIP)(*FAIL)|\\d*\\s?\\d+\\\/\\d+"*\\s*(in|")', 'gm')
const str = `A product description with 12 1/2" in it.
Product description with 19 3/4" x 19 5/8" in it.`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);