import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d*\\s?\\d+\\/\\d+\"*\\s*(in|\")\\sx\\s\\d*\\s?\\d+\\/\\d+\"*\\s*(in|\")(*SKIP)(*FAIL)|\\d*\\s?\\d+\\/\\d+\"*\\s*(in|\")";
final String string = "A product description with 12 1/2\" in it.\n"
+ "Product description with 19 3/4\" x 19 5/8\" in it.";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}