re = /\d*\s?\d+\/\d+"*\s*(in|")\sx\s\d*\s?\d+\/\d+"*\s*(in|")(*SKIP)(*FAIL)|\d*\s?\d+\/\d+"*\s*(in|")/m
str = 'A product description with 12 1/2" in it.
Product description with 19 3/4" x 19 5/8" in it.'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result