using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d*\s?\d+\/\d+""*\s*(in|"")\sx\s\d*\s?\d+\/\d+""*\s*(in|"")(*SKIP)(*FAIL)|\d*\s?\d+\/\d+""*\s*(in|"")";
string substitution = @" ";
string input = @"A product description with 12 1/2"" in it.
Product description with 19 3/4"" x 19 5/8"" in it.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}