#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*(?<!_test)\.txt$)"
Local $sString = "somepath/testFile.txt" & @CRLF & _
"somepath/test_File.txt" & @CRLF & _
"somepath/testFile_test.txt" & @CRLF & _
"somepath/testFile.txtTEMP"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)