$re = '/^(.*(?<!_test)\.txt$)/m';
$str = 'somepath/testFile.txt
somepath/test_File.txt
somepath/testFile_test.txt
somepath/testFile.txtTEMP';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;