const regex = /^(.*(?<!_test)\.txt$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*(?<!_test)\\.txt$)', 'gm')
const str = `somepath/testFile.txt
somepath/test_File.txt
somepath/testFile_test.txt
somepath/testFile.txtTEMP`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);