using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*(?<!_test)\.txt$)";
string substitution = @" ";
string input = @"somepath/testFile.txt
somepath/test_File.txt
somepath/testFile_test.txt
somepath/testFile.txtTEMP";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}